Jump to content

Gen3 motor failure 300 miles on 1/4 mile


mark3evo
 Share

Recommended Posts

9 hours ago, Kzin said:

Not at 300 miles you haven't....

true, but as it said incorrect valve lash- engine not to spec

pretty sure JD took my engine to the rev limiter during recent engine break-in 

Link to comment
Share on other sites

This could have happend to anyone, Suzuki are making so many engines that there is going to be a % that will have a fualt.

It's just a shame that this engine was used for racing from the off. just a bit of bad luck really.

The guy has 5 Gen3 busa's and has had loads of Gen1 & Gen2 and as he said this is the first time this has happend. I think he's been very lucky over the years.

Link to comment
Share on other sites

sorry but it would just make a noise with a big clearance and as you said you should hear it . 

it has to be revved to valve spring bounce for the valve to float

one tap from the piston and the keeper comes out.

but the springs/valves  have to be floating for this to happen

ie totally out of control and out of timing with the piston and cam.

a big valve clearance is not going to let this happen unless you are on the limit or just past it .

which is why you have competition springs and valves.

engines on the dyno exceed their parameters often at 50 - 800 miles from new :whistling:

 

but fair play to him for doing good detective work in identifying a potential problem .

how many of these does it need for a recall :whistling::D

Link to comment
Share on other sites

35 minutes ago, madmattt said:

That's a good question John. Dare I ask if you have had a failure on the dynon with a new build?

yes one in 25 years

2nd run, lost oil pressure and spun a shell on a big end due to blocked badly designed invisible Custom suction strainer screen .

it became visible when the custom suction strainer was dismantled. And a badly designed mesh screen  discovered, unfortunate for us.

if the owner had done one more run before it came to us it would have happened to him . he was not aware there was a internal screen . 

took the crank and a rod .

 

one of my friends brought a blackbird engine to us to test. Torpedo was working for me then and had hold of the throttle 

Brand new vance and hines big valve cylinder head . valve seat came out 2nd or 3rd run.

tinkle rattle rattle , 3 cylinders.

normally long faces all round but Dave been Dave laughed , he sure does know how to make friends 

the engine was built by the electrician for one of his grasstrack cars you may remember 

Link to comment
Share on other sites

Also when watching that first vid - though it's hard to tell, the follower tops look like they show signs of wear. If this is the case, that's very hard to do under normal wear, and not at 300 miles...

:thumbs:

edit : some of them. :D

Link to comment
Share on other sites

3 hours ago, madmattt said:

@JOHN-DYNOSTAR :bounce: So nothing you fitted went wrong, so a zero in 25 years i reckon :bounce:

 

Give if time :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy